Supported Browsers

YouCanBook.me requires an up-to-date web browser to make sure that you can use all of our features.

We support the current versions of: 

Unsupported Browsers

If you see an "unsupported browser" or "ERR_SSL_VERSION_OR_CIPHER_MISMATCH" browser error, you need to update your browser to the latest version.

If you have updated your browser but you still see the message, then clear the cache on your browser. The steps to clear your cache vary depending on your browser. To see more details, go to How to clear cookies in Chrome, Firefox, Safari, and other browsers.

How this affects your booker

Your booker needs to use an up to date browser to access your booking page. If your bookers report an error similar to the one in the screenshot below when visiting your booking page - they are using an unsupported browser. Please direct them to update their browser so they can continue booking with you.

TLS

Transport Layer Security (TLS) is a cryptographic protocol designed to provide communications security over a computer network.

Why are the older versions no longer supported?

TLS 1.0 and 1.1 are 20 and 13 years old, respectively. Neither are compliant with today’s PCI Data Security Standards (PCI DSS) for safeguarding payment data, and they are unable to support modern cryptographic algorithms. They are both vulnerable to security exploits that could expose booker or user data. 

Which browsers are affected?

Firefox, Google Chrome, Microsoft Edge and Internet Explorer 11, and Apple’s Safari are all revoking support for TLS 1.0/1.1 by 2020. To continue browsing websites you will need to update to the latest version of your browser of choice.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us